Some stores unable to purchase DHL Express shipping labels.
Incident Report for Shopify
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 03, 2018 - 11:44 EST
Monitoring
Some stores are temporarily unable to purchase DHL Express shipping labels from the fulfillment page in the Shopify admin. Shipping options are working normally for customers at checkout--only the purchase of shipping labels from within the admin is affected.

We’re working on a solution and will keep you updated.
Posted 4 months ago. Mar 03, 2018 - 11:29 EST
This incident affected: Third party services.