Some stores unable to purchase USPS shipping labels.
Incident Report for Shopify
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 13, 2018 - 23:27 EDT
Monitoring
Some stores are temporarily unable to purchase USPS shipping labels from the fulfillment page in the Shopify admin. Shipping options are working normally for customers at checkout--only the purchase of shipping labels from within the admin is affected.

We’re working on a solution and will keep you updated.
Posted 2 months ago. Sep 13, 2018 - 23:20 EDT
This incident affected: Third party services.