Some stores unable to purchase USPS shipping labels.
Incident Report for Shopify
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 15, 2018 - 00:18 EST
Monitoring
Some stores are temporarily unable to purchase USPS shipping labels from the fulfillment page in the Shopify admin. Shipping options are working normally for customers at checkout--only the purchase of shipping labels from within the admin is affected.

We’re working on a solution and will keep you updated.
Posted 3 months ago. Dec 14, 2018 - 23:35 EST
This incident affected: Third party services.