Amazon Pay not working for some stores
Incident Report for Shopify
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 22, 2019 - 17:09 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Aug 22, 2019 - 16:52 EDT
Investigating
We are currently investigating an issue where Amazon Pay is experiencing an interruption in service preventing payments from being processed for some stores. We’re working on a solution and will keep you updated.
Posted about 1 month ago. Aug 22, 2019 - 16:46 EDT
This incident affected: Checkout.