Some stores unable to purchase UPS shipping labels.
Incident Report for Shopify
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 12, 2018 - 10:52 EST
Monitoring
Some stores are temporarily unable to purchase UPS shipping labels from the fulfillment page in the Shopify admin. Shipping options are working normally for customers at checkout--only the purchase of shipping labels from within the admin is affected.

We’re working on a solution and will keep you updated.
Posted about 1 month ago. Nov 12, 2018 - 10:44 EST
This incident affected: Third party services.