Some stores unable to purchase USPS shipping labels.
Incident Report for Shopify
Resolved
This incident has been resolved.
Posted 27 days ago. Aug 26, 2019 - 22:27 EDT
Update
Some stores are temporarily unable to purchase USPS shipping labels from the fulfillment page in the Shopify admin. Shipping rates are working normally for customers at checkout—only the purchase of shipping labels from within the admin is affected.

We're continuing to investigate a solution and will keep you updated.
Posted 28 days ago. Aug 26, 2019 - 19:58 EDT
Monitoring
Some stores are temporarily unable to purchase USPS shipping labels from the fulfillment page in the Shopify admin. Shipping options are working normally for customers at checkout--only the purchase of shipping labels from within the admin is affected.

We’re working on a solution and will keep you updated.
Posted 28 days ago. Aug 26, 2019 - 19:01 EDT
This incident affected: Third party services.