Shopify Flow workflows
Incident Report for Shopify
Resolved
This incident has been resolved.
Posted 14 days ago. Sep 09, 2019 - 18:32 EDT
Investigating
Shopify Flow is currently experiencing delays for some Shopify Plus stores. We are investigating and will keep you updated.
Posted 14 days ago. Sep 09, 2019 - 17:39 EDT