Some stores unable to purchase UPS shipping labels.
Incident Report for Shopify
Resolved
This incident has been resolved.
Posted 12 days ago. Aug 04, 2018 - 11:52 EDT
Monitoring
Some stores are temporarily unable to purchase UPS shipping labels from the fulfillment page in the Shopify admin. Shipping options are working normally for customers at checkout--only the purchase of shipping labels from within the admin is affected.

We’re working on a solution and will keep you updated.
Posted 12 days ago. Aug 04, 2018 - 10:31 EDT
This incident affected: Third party services.