Problem buying shipping labels from DHL Express.
Incident Report for Shopify
Resolved
This incident has been resolved.
Posted 11 months ago. Dec 04, 2017 - 15:38 EST
Monitoring
DHL Express is experiencing an unexpected technical issue. This means you can’t buy DHL Express shipping labels in Shopify.

We'll post an update on this page when DHL Express is back up and running.
Posted 11 months ago. Dec 04, 2017 - 15:26 EST
This incident affected: Third party services.