Problem buying shipping labels from USPS.
Incident Report for Shopify
Resolved
This incident has been resolved.
Posted 6 months ago. Feb 06, 2018 - 11:09 EST
Monitoring
USPS is experiencing an unexpected technical issue. This means you can’t buy USPS shipping labels in Shopify.

We'll post an update on this page when USPS is back up and running.
Posted 6 months ago. Feb 06, 2018 - 10:41 EST
This incident affected: Third party services.