Unable to create new stores on Shopify.com, access Payments section of Shopify admin and purchase shipping labels
Incident Report for Shopify
Resolved
This issue was resolved and Shopify.com is working normally. The Payments section of the Shopify admin is loading as expected, and you are able to purchase labels once again. The monitoring period for this issue has ended and no further impact has been observed.
Posted 18 days ago. Nov 28, 2018 - 11:48 EST
Investigating
We are experiencing an issue with creating new stores on Shopify.com, accessing the Payments section of the Shopify admin and purchasing shipping labels.
Posted 18 days ago. Nov 28, 2018 - 11:42 EST