Some stores unable to purchase DHL Express shipping labels
Incident Report for Shopify
Resolved
This incident has been resolved.
Posted 30 days ago. Sep 23, 2019 - 15:43 EDT
Monitoring
Some stores are temporarily unable to purchase shipping labels from the fulfillment page in the Shopify admin. Shipping options are working normally for customers at checkout--only the purchase and printing of shipping labels from within the admin is affected. We’re investigating and will keep you updated.
Posted 30 days ago. Sep 23, 2019 - 12:30 EDT
This incident affected: Third party services.